Scooby-Doo requires the latest flash player, but don't worry!
You can download it here.

Click here to download the latest player.